desktop/qjson/PKGBUILD
AlmAck 0af05b343a kde applications 16.12.0
renamed checksums to kdeapps.sums
added for all packages the pgp signature
for new/removed packages check: https://community.kde.org/Applications/16.12_Release_Notes#Tarballs_that_we_have_split
2016-12-20 21:48:24 +00:00

34 lines
735 B
Bash

# abveritas@chakra-project@org>
# Include global configuration
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=qjson
pkgver=0.8.1
pkgrel=1
pkgdesc="A qt-based library that maps JSON data to QVariant objects."
arch=('x86_64')
license=('GPL')
url="http://qjson.sourceforge.net"
depends=('qt')
makedepends=('cmake')
source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/flavio/${pkgname}/archive/${pkgver}.tar.gz")
md5sums=('4eef13da988edf8f91c260a3e1baeea9')
options=('!debug')
groups=("kde-uninstall" "kde-support")
build() {
cd $srcdir
mkdir -p build
cd build
cmake ../${pkgname}-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd $srcdir/build
make DESTDIR=${pkgdir} install
}