mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
85e0476b66
It replaces the gcompris package from [gtk], as it is no longer maintained and has been replaced by the Qt version. GCompris also replaces kde-pairs, which has been abandoned in favor of the former.
26 lines
594 B
Bash
26 lines
594 B
Bash
|
|
pkgname=qml-box2d
|
|
pkgver=0.1
|
|
_commit=fb35cf18fc74b1b68b353605c9799d08adaa81f9
|
|
pkgrel=3
|
|
pkgdesc="Expose the functionality of Box2D as QML components, in order to make it easy to write physics based games in QML."
|
|
url="https://github.com/qml-box2d/qml-box2d"
|
|
arch=('x86_64')
|
|
license=('LGPL')
|
|
depends=('qt5-declarative')
|
|
source=("https://github.com/qml-box2d/qml-box2d/archive/${_commit}.zip")
|
|
md5sums=('830c5ff6c677bb45ff529f2cea0289f9')
|
|
|
|
build() {
|
|
cd $pkgname-${_commit}
|
|
|
|
/usr/lib/qt5/bin/qmake
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname-${_commit}
|
|
|
|
make INSTALL_ROOT=$pkgdir install
|
|
}
|