mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
24 lines
708 B
Bash
24 lines
708 B
Bash
# Contributions from Arch: https://www.archlinux.org/packages/community/any/setconf/
|
|
|
|
pkgname=setconf
|
|
pkgver=0.7.5
|
|
pkgrel=1
|
|
pkgdesc='Utility for easily changing settings in configuration files'
|
|
arch=('x86_64')
|
|
url="https://setconf.roboticoverlords.org/"
|
|
license=('GPL')
|
|
depends=('python2')
|
|
source=("https://setconf.roboticoverlords.org/$pkgname-$pkgver.tar.xz")
|
|
sha256sums=('3aa5ded4c3e1996a78cbbcbd7b9af051e3a197f6e79fced9ebb118da902a52fe')
|
|
|
|
prepare() {
|
|
sed -i 's:usr/bin/python$:usr/bin/python2:' "$pkgname-$pkgver/$pkgname.py"
|
|
}
|
|
|
|
package() {
|
|
cd "$pkgname-$pkgver"
|
|
|
|
install -Dm755 "$pkgname.py" "$pkgdir/usr/bin/$pkgname"
|
|
install -Dm644 "$pkgname.1.gz" "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
|
|
}
|