desktop/shiboken2/PKGBUILD
2019-02-10 14:54:22 +01:00

45 lines
1.1 KiB
Bash

pkgbase=shiboken2
pkgname=('shiboken2' 'python-shiboken2')
_qtver=5.12.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(x86_64)
url='https://www.qt.io/'
license=('GPL2' 'LGPL')
pkgdesc='Generates bindings for C++ libraries using CPython source code'
makedepends=('clang' 'llvm' 'cmake' 'libxslt' 'qt5-xmlpatterns' 'python3-sphinx')
_pkgfqn=pyside-setup-everywhere-src-${_qtver}
source=("https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz")
sha256sums=('6e26b6240b97558b8bf3c97810e950ef4121a03a1ebdecfb649992a505f18059')
prepare() {
mkdir -p build
}
build() {
cd build
cmake ../${_pkgfqn}/sources/shiboken2 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTS=OFF \
-DUSE_PYTHON_VERSION=3
make
}
package_shiboken2() {
depends=('clang' 'libxslt' 'qt5-xmlpatterns')
cd build
make DESTDIR="$pkgdir" install
# Provided in python-shiboken2
rm -r "$pkgdir"/usr/lib/{python*,libshiboken*}
}
package_python-shiboken2() {
depends=('python3')
cd build
make DESTDIR="$pkgdir" install
# Provided in shiboken2
rm -r "$pkgdir"/usr/{bin,include,lib/{cmake,pkgconfig},share}
}