mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
28 lines
885 B
Bash
28 lines
885 B
Bash
pkgname=smtube
|
|
pkgver=18.11.0
|
|
pkgrel=1
|
|
pkgdesc="Search and download videos from YouTube"
|
|
arch=('x86_64')
|
|
url="https://www.smtube.org/"
|
|
license=('GPL')
|
|
depends=('qt5-script' 'qt5-webkit' 'desktop-file-utils' 'hicolor-icon-theme')
|
|
makedepends=('qt5-tools')
|
|
optdepends=('mplayer: play videos with MPlayer'
|
|
'smplayer: play videos with SMPlayer'
|
|
'dragon: play videos with Dragon Player'
|
|
'vlc: play videos with VLC'
|
|
'mpv: play videos with MPV'
|
|
'youtube-dl: download videos')
|
|
source=("https://downloads.sourceforge.net/smtube/${pkgname}-${pkgver}.tar.bz2")
|
|
sha256sums=('173f7f0902d336ef423b2074654bef461326ee6fba669f54865c81ac5b3daa65')
|
|
|
|
build() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
make QMAKE=qmake-qt5 LRELEASE=lrelease-qt5 PREFIX=/usr
|
|
}
|
|
|
|
package() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
make PREFIX=/usr DESTDIR="$pkgdir/" install
|
|
}
|