mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
28 lines
1.1 KiB
Bash
28 lines
1.1 KiB
Bash
pkgname=spideroak
|
|
_PkgName=SpiderOakONE
|
|
pkgver=7.4.0
|
|
pkgrel=2
|
|
pkgdesc="Secure and consolidated free online backup, storage, access, sharing & sync tool for Windows, Mac OS X, and Linux."
|
|
url="https://spideroak.com/"
|
|
arch=('x86_64')
|
|
depends=('glibc' 'desktop-file-utils')
|
|
license=('custom')
|
|
categories=('network')
|
|
screenshot=('https://spideroak.com/static/v0.1/main/images/screenshots/new/view-versions.png')
|
|
options=(!strip)
|
|
source=("spideroakone_${pkgver}_amd64.deb::https://spideroak.com/release/spideroak/deb_x64"
|
|
"terms.txt")
|
|
sha256sums=('1a606320742ac3d020d4d0180abaf03cfb75574c83f18b4f09e7eb026213a5a9'
|
|
'4819c8d923ab19e552e877b87adf1d45aca6adcb5dffcb238d7819501e6e6737')
|
|
|
|
package() {
|
|
tar -xf "${srcdir}"/data.tar.xz -C "$pkgdir"/
|
|
|
|
install -Dm644 "$srcdir"/terms.txt "$pkgdir"/usr/share/licenses/$pkgname/terms.txt
|
|
|
|
rm -r "$pkgdir"/etc/apt/
|
|
rm -r "$pkgdir"/etc/xdg/menus/applications-merged/SpiderOakONE.menu
|
|
mv "$pkgdir"/opt/SpiderOakONE/lib/libz.so.1 "$pkgdir"/opt/SpiderOakONE/lib/libz.so.1.bak
|
|
ln -s "$pkgdir"/usr/lib/libz.so.1 "$pkgdir"/opt/SpiderOakONE/lib
|
|
}
|