mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
0af05b343a
renamed checksums to kdeapps.sums added for all packages the pgp signature for new/removed packages check: https://community.kde.org/Applications/16.12_Release_Notes#Tarballs_that_we_have_split
43 lines
1.1 KiB
Bash
43 lines
1.1 KiB
Bash
|
|
# Maintainer (i686): Phil Miller <philm@chakra-project[dog]org>
|
|
# Maintainer (x86_64): Manuel Tortosa <manutortosa@chakra-project@org>
|
|
|
|
pkgname=dbusmenu-qt-git
|
|
pkgver=20101019
|
|
pkgrel=1
|
|
pkgdesc="A standalone library providing a way to import and export QMenu instances using the DBusMenu protocol."
|
|
arch=('i686' 'x86_64')
|
|
license=('GPL')
|
|
depends=('qt' 'qjson')
|
|
makedepends=('git' 'cmake')
|
|
url="http://gitorious.org/dbusmenu/"
|
|
conflicts=('dbusmenu-qt')
|
|
provides=('dbusmenu-qt')
|
|
source=(http://chakra-project.org/sources/${pkgname}/${pkgname}-${pkgver}.tar.xz)
|
|
md5sums=(a4fa14066609b87935800f7a0d5077f4)
|
|
|
|
# create tarball: source PKGBUILD && mksource
|
|
|
|
mksource() {
|
|
git clone git://gitorious.org/dbusmenu/dbusmenu-qt.git
|
|
pushd dbusmenu-qt
|
|
popd
|
|
tar -cvJf ${pkgname}-${pkgver}.tar.xz dbusmenu-qt/*
|
|
md5sum ${pkgname}-${pkgver}.tar.xz
|
|
}
|
|
|
|
build() {
|
|
cd $srcdir
|
|
|
|
mkdir -p $srcdir/dbusmenu-qt-build
|
|
|
|
cd $srcdir/dbusmenu-qt-build
|
|
|
|
cmake ${srcdir}/dbusmenu-qt -DCMAKE_BUILD_TYPE=Release \
|
|
-DCMAKE_INSTALL_PREFIX=/usr
|
|
make
|
|
make DESTDIR=$pkgdir install
|
|
|
|
rm -rf $srcdir/dbusmenu-qt-build
|
|
}
|