mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
0af05b343a
renamed checksums to kdeapps.sums added for all packages the pgp signature for new/removed packages check: https://community.kde.org/Applications/16.12_Release_Notes#Tarballs_that_we_have_split
83 lines
2.5 KiB
Bash
83 lines
2.5 KiB
Bash
|
|
# Chakra Packages for Chakra, part of chakra-project.org
|
|
|
|
# Maintainer abveritas@chakra-project.org
|
|
|
|
# package info
|
|
|
|
pkgname=tribe-netinst
|
|
provides=tribe
|
|
replaces=tribe
|
|
conflicts=tribe
|
|
pkgver=2013.02.17
|
|
_rls_notes=20130209
|
|
pkgrel=1
|
|
_codename=Benz
|
|
pkgdesc="Tribe - Chakra LiveCD Installer"
|
|
url="http://git.chakra-project.org/chakra/"
|
|
license="GPL"
|
|
arch=('x86_64')
|
|
depends=('kdelibs' 'kdeedu-marble>=4.10.0' 'squashfs-tools' 'tribe-partitionmanager'
|
|
'cinstall>=0.4.6.10' 'rsync' 'mkinitcpio-nfs-utils' 'ntfs-3g' 'libpwquality')
|
|
makedepends=('cmake' 'kde-workspace' 'automoc4')
|
|
options=('!debug')
|
|
source=("${pkgname}-${pkgver}.tar.xz"
|
|
"http://chakra-linux.org/sources/tribe/RELEASE_NOTES_${_rls_notes}.html"
|
|
'launch-tribe.sh')
|
|
md5sums=('2de910453ec60cea391cb7d2e02052e8'
|
|
'd7bf7d3628d4cff05711f842e61c0417'
|
|
'e31855da237a2c8029774831b3c04685')
|
|
|
|
groups=('kde-uninstall')
|
|
categories=('system')
|
|
install=tools-tribe.install
|
|
|
|
# create tarball: source PKGBUILD && mksource
|
|
|
|
mksource() {
|
|
rm -vRf ${pkgname}-${pkgver}
|
|
git clone git://gitorious.org/chakra/tribe.git ${pkgname}-${pkgver}
|
|
#git clone git://github.com/abveritas/Tribe.git ${pkgname}-${pkgver}
|
|
#git clone git://github.com/Inkane/Tribe.git ${pkgname}-${pkgver}
|
|
rm -vRf ${pkgname}-${pkgver}/.git
|
|
pushd ${pkgname}-${pkgver}
|
|
popd
|
|
tar -cvJf ${pkgname}-${pkgver}.tar.xz ${pkgname}-${pkgver}/*
|
|
md5sum ${pkgname}-${pkgver}.tar.xz
|
|
}
|
|
|
|
# build function
|
|
|
|
build()
|
|
{
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
# proper bootmnt folder
|
|
sed -i -e "s/@ARCH@/${CARCH}/g" config-tribe.h.cmake
|
|
|
|
# add pkgver to tribe
|
|
sed -i -e "s~source build/from git~Build: ${pkgver} ($_codename)~g" config-tribe.h.cmake
|
|
sed -i -e "s~code-name~$_codename~g" "scripts/postinstall-functions/01-job-initialize-target"
|
|
sed -i -e "s~chakra-version~${pkgver}~g" "scripts/postinstall-functions/01-job-initialize-target"
|
|
cmake . -DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DCMAKE_BUILD_TYPE=Release \
|
|
-DCMAKE_SKIP_RPATH=ON \
|
|
-DCMAKE_{SHARED,MODULE,EXE}_LINKER_FLAGS='-Wl,--no-undefined -Wl,--as-needed'
|
|
|
|
msg "Starting make..."
|
|
make
|
|
}
|
|
|
|
package()
|
|
{
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
msg "Make successful, installing..."
|
|
make DESTDIR=${pkgdir} install
|
|
install -Dm755 ${srcdir}/launch-tribe.sh \
|
|
${pkgdir}/usr/bin/launch-tribe.sh
|
|
cp -vf ${srcdir}/RELEASE_NOTES_${_rls_notes}.html $pkgdir/usr/share/tribe/config/RELEASE_NOTES.html
|
|
|
|
# remove nasty files
|
|
find ${pkgdir}/ -name ".git" -type d -exec rm -fr {} +
|
|
}
|