mirror of
https://gitdl.cn/https://github.com/chakralinux/gtk.git
synced 2025-02-03 03:17:14 +08:00
33 lines
1.0 KiB
Bash
33 lines
1.0 KiB
Bash
pkgname=emacs
|
|
pkgver=26.1
|
|
pkgrel=2
|
|
pkgdesc="The extensible, customizable, self-documenting real-time display editor"
|
|
arch=('x86_64')
|
|
url="https://www.gnu.org/software/emacs/emacs.html"
|
|
license=('GPL3')
|
|
depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk3' 'hicolor-icon-theme' 'desktop-file-utils'
|
|
'alsa-lib' 'libmagick6' 'gnutls')
|
|
conflicts=('emacs-nox')
|
|
install=emacs.install
|
|
source=(ftp://ftp.gnu.org/gnu/emacs/$pkgname-$pkgver.tar.xz)
|
|
md5sums=('649ec46965a8b842bdb2cbf7764c2a9a')
|
|
|
|
build() {
|
|
cd "$srcdir"/$pkgname-$pkgver
|
|
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
|
|
--localstatedir=/var --with-x-toolkit=gtk3 --with-xft --with-modules
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "$srcdir"/$pkgname-$pkgver
|
|
make DESTDIR="$pkgdir" install
|
|
|
|
# remove conflict with ctags package
|
|
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
|
|
mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
|
|
|
|
# fix user/root permissions on usr/share files
|
|
find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
|
|
}
|