mirror of
https://gitdl.cn/https://github.com/chakralinux/gtk.git
synced 2025-02-03 02:27:14 +08:00
26 lines
715 B
Bash
26 lines
715 B
Bash
pkgname=ibus-libzhuyin
|
|
pkgver=1.9.0
|
|
pkgrel=1
|
|
pkgdesc="New Zhuyin engine based on libzhuyin for IBus."
|
|
arch=('x86_64')
|
|
license=('GPL')
|
|
url="https://github.com/libzhuyin/ibus-libzhuyin"
|
|
depends=('ibus' 'gettext' 'intltool' 'sqlite3' 'opencc' 'libpinyin' 'python3')
|
|
source=("https://downloads.sourceforge.net/libzhuyin/${pkgname}/${pkgname}-${pkgver}.tar.gz")
|
|
sha1sums=('9713399e560146cc8aa7453cb3182377e208fbfa')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
./configure --prefix=/usr \
|
|
--libexecdir=/usr/lib/ibus \
|
|
--disable-static \
|
|
--disable-boost \
|
|
--with-python=python3
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
make DESTDIR="${pkgdir}" install
|
|
}
|