mirror of
https://gitdl.cn/https://github.com/chakralinux/gtk.git
synced 2025-01-23 17:33:32 +08:00
25 lines
621 B
Bash
25 lines
621 B
Bash
pkgname=ibus-qt
|
|
pkgver=1.3.3
|
|
pkgrel=2
|
|
pkgdesc='IBus qt library and IBus qt input method plugin'
|
|
arch=('x86_64')
|
|
license=('LGPL')
|
|
url='https://github.com/ibus'
|
|
depends=('qt' 'ibus' 'icu')
|
|
makedepends=('cmake' 'automoc4' 'doxygen')
|
|
source=("https://github.com/ibus/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-Source.tar.gz")
|
|
md5sums=('952fa987dc3675dc1df7721b552770c1')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}-Source"
|
|
mkdir -p build && cd build
|
|
|
|
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}-Source/build"
|
|
make DESTDIR="${pkgdir}" install
|
|
}
|