mirror of
https://gitdl.cn/https://github.com/chakralinux/gtk.git
synced 2025-01-23 17:33:32 +08:00
29 lines
1007 B
Bash
29 lines
1007 B
Bash
pkgname=playonlinux
|
|
pkgver=4.3.3
|
|
pkgrel=1
|
|
pkgdesc="GUI for managing Windows programs under linux"
|
|
url="http://www.playonlinux.com/"
|
|
license=('GPL')
|
|
depends=('wine' 'imagemagick' 'xterm' 'wxpython' 'cabextract' 'unzip' 'mesa-demos'
|
|
'xdg-user-dirs' 'gnu-netcat' 'gnupg' 'icoutils' 'libxmu' 'wget' 'p7zip')
|
|
arch=('x86_64')
|
|
source=(http://www.playonlinux.com/script_files/PlayOnLinux/${pkgver/.0/}/PlayOnLinux_${pkgver/.0/}.tar.gz)
|
|
options=(!strip)
|
|
md5sums=('b3f61c47c6025281657e4d996f858f8e')
|
|
screenshot=('http://i.imgur.com/77mGY.png')
|
|
|
|
package() {
|
|
|
|
install -d $pkgdir/usr/share/$pkgname
|
|
install -d $pkgdir/usr/bin
|
|
|
|
cp -r $pkgname/ $pkgdir/usr/share/
|
|
|
|
echo "#!/bin/bash" > $pkgdir/usr/bin/$pkgname
|
|
echo "/usr/share/$pkgname/$pkgname \"\$@\"" >> $pkgdir/usr/bin/$pkgname
|
|
chmod +x $pkgdir/usr/bin/$pkgname
|
|
|
|
install -D -m644 $pkgname/etc/PlayOnLinux.desktop $pkgdir/usr/share/applications/playonlinux.desktop
|
|
sed -i "s/ %F//g" $pkgdir/usr/share/applications/playonlinux.desktop
|
|
}
|