mirror of
https://gitdl.cn/https://github.com/chakralinux/lib32.git
synced 2025-02-09 12:28:32 +08:00
64 lines
2.1 KiB
Bash
64 lines
2.1 KiB
Bash
# Lib32 Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer (x86_64): Giuseppe Calà <jiveaxe@gmail.com>
|
|
# maintainer (x86_64): Anke Boersma <abveritas[at]chakra-project[dot]org>
|
|
|
|
_pkgbasename=freetype2
|
|
pkgname=lib32-$_pkgbasename
|
|
pkgver=2.6.3
|
|
pkgrel=1
|
|
pkgdesc="TrueType font rendering library (32-bit)"
|
|
arch=(x86_64)
|
|
license=('GPL')
|
|
url="http://www.freetype.org/"
|
|
# adding harfbuzz for improved OpenType features auto-hinting
|
|
# introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
|
|
depends=('lib32-zlib' 'lib32-bzip2' 'lib32-libpng' 'lib32-harfbuzz' "$_pkgbasename=$pkgver")
|
|
makedepends=(gcc-multilib)
|
|
source=(http://download.savannah.gnu.org/releases/freetype/freetype-${pkgver}.tar.bz2{,.sig}
|
|
0001-Enable-table-validation-modules.patch
|
|
0002-Enable-subpixel-rendering.patch
|
|
0003-Enable-subpixel-hinting.patch
|
|
0004-Mask-subpixel-hinting-with-an-env-var.patch)
|
|
sha1sums=('6c98bd5d0be313207c37ca23d25faf983486aee5'
|
|
'SKIP'
|
|
'1c7bc438df0428a63f881e7e4343b22c5b09ecb1'
|
|
'e2d2b8c4847ab9cfd497179c7140835e99ece711'
|
|
'ebe3d7a6fc41304a77c23cb56e94dc718146d963'
|
|
'f50c70080f3fbee45b9c4264d8ae37eb4f1ac335')
|
|
validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
|
|
|
|
prepare() {
|
|
cd "${srcdir}/freetype-${pkgver}"
|
|
patch -Np1 -i "${srcdir}/0001-Enable-table-validation-modules.patch"
|
|
patch -Np1 -i "${srcdir}/0002-Enable-subpixel-rendering.patch"
|
|
|
|
# https://bugs.archlinux.org/task/35274
|
|
patch -Np1 -i "${srcdir}/0003-Enable-subpixel-hinting.patch"
|
|
# Provide a way to enable the above patch at runtime.
|
|
# Hopefully just a temporary measure until fontconfig picks up
|
|
# the necessary configurables.
|
|
patch -Np1 -i "${srcdir}/0004-Mask-subpixel-hinting-with-an-env-var.patch"
|
|
}
|
|
|
|
build() {
|
|
export CC="gcc -m32"
|
|
export CXX="g++ -m32"
|
|
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
|
|
|
|
cd "${srcdir}/freetype-${pkgver}"
|
|
./configure --prefix=/usr --libdir=/usr/lib32
|
|
make
|
|
}
|
|
|
|
check() {
|
|
cd "${srcdir}/freetype-${pkgver}"
|
|
make -k check
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/freetype-${pkgver}"
|
|
make DESTDIR="${pkgdir}" install
|
|
rm -r "${pkgdir}"/usr/{include,share,bin}
|
|
}
|