mirror of
https://gitdl.cn/https://github.com/chakralinux/lib32.git
synced 2025-01-24 01:42:15 +08:00
37 lines
1.1 KiB
Bash
37 lines
1.1 KiB
Bash
# Maintainer: AlmAck <almack@chakraos.org>
|
|
|
|
_pkgbasename=elfutils
|
|
pkgname=lib32-elfutils
|
|
pkgver=0.167
|
|
pkgrel=1
|
|
pkgdesc="Collection of libraries for working with ELF object files and DWARF debugging information (32-bit)"
|
|
arch=('x86_64')
|
|
url="https://fedorahosted.org/elfutils/"
|
|
license=('LGPL3' 'GPL' 'GPL3')
|
|
depends=('lib32-bzip2' 'lib32-zlib' $_pkgbasename=$pkgver)
|
|
makedepends=('lib32-gcc-libs')
|
|
source=(https://fedorahosted.org/releases/e/l/elfutils/${pkgver}/elfutils-${pkgver}.tar.bz2{,.sig})
|
|
options=('staticlibs')
|
|
sha1sums=('91cec7fec0031758cc0c842a87ee8c5faa4d8107'
|
|
'SKIP')
|
|
validpgpkeys=('47CC0331081B8BC6D0FD4DA08370665B57816A6A') # Mark J. Wielaard <mark@klomp.org>
|
|
|
|
build() {
|
|
cd ${srcdir}/${_pkgbasename}-${pkgver}
|
|
|
|
export CC="gcc -m32"
|
|
export CXX="g++ -m32"
|
|
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
|
|
CFLAGS+=" -g" # required for test-suite success
|
|
|
|
./configure --prefix=/usr --libdir=/usr/lib32
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${srcdir}/${_pkgbasename}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
rm -rf ${pkgdir}/usr/{bin,include,share}
|
|
}
|