43 lines
1.2 KiB
Bash
43 lines
1.2 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=curl
|
|
pkgver=8.9.1
|
|
pkgrel=1
|
|
pkgdesc="command line tool and library for transferring data with URLs"
|
|
arch=('x86_64')
|
|
url="https://curl.se/"
|
|
license=('MIT')
|
|
depends=('zlib' 'zstd')
|
|
source=(https://curl.se/download/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(f292f6cc051d5bbabf725ef85d432dfeacc8711dd717ea97612ae590643801e5)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-static \
|
|
--with-openssl \
|
|
--enable-threaded-resolver \
|
|
--with-ca-path=/etc/ssl/certs
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
|
|
find docs \( -name Makefile\* -o \
|
|
-name \*.1 -o \
|
|
-name \*.3 -o \
|
|
-name CMakeLists.txt \) -delete
|
|
|
|
install -vdm755 ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
|
|
cp -v -R docs -T ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
|
|
}
|