41 lines
1.1 KiB
Bash
41 lines
1.1 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=e2fsprogs
|
|
pkgver=1.47.1
|
|
pkgrel=1
|
|
pkgdesc="Ext2/3/4 filesystem utilities"
|
|
arch=('x86_64')
|
|
url="http://e2fsprogs.sourceforge.net/"
|
|
license=('GPL' 'LGPL' 'MIT')
|
|
depends=('bash' 'util-linux')
|
|
makedepends=('systemd')
|
|
source=(https://downloads.sourceforge.net/project/e2fsprogs/e2fsprogs/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(9afcd201f39429d2db2492aeb13dba5e75d6cc50682b732dca35643bd5f092e3)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
mkdir -v build
|
|
cd build
|
|
|
|
${BUILD_CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--enable-elf-shlibs \
|
|
--disable-libblkid \
|
|
--disable-libuuid \
|
|
--disable-uuidd \
|
|
--disable-fsck
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}/build
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|