32 lines
853 B
Bash
32 lines
853 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=findutils
|
|
pkgver=4.10.0
|
|
pkgrel=1
|
|
pkgdesc="GNU utilities to locate files"
|
|
arch=('x86_64')
|
|
url="https://www.gnu.org/software/findutils/"
|
|
license=('GPL-3.0-or-later')
|
|
groups=('base' 'base-devel')
|
|
depends=('glibc' 'bash')
|
|
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(1387e0b67ff247d2abde998f90dfbf70c1491391a59ddfecb8ae698789f0a4f5)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --localstatedir=/var/lib/locate
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|