Core/gdbm/PKGBUILD
2024-09-07 23:18:11 +08:00

34 lines
867 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=gdbm
pkgver=1.24
pkgrel=1
pkgdesc="GNU database library"
arch=('x86_64')
url="https://www.gnu.org/software/gdbm/"
license=('GPL-3.0-or-later')
depends=('glibc' 'bash')
makedepends=('readline')
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
sha256sums=(695e9827fdf763513f133910bc7e6cfdb9187943a4fec943e57449723d2b8dbf)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--disable-static \
--enable-libgdbm-compat
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}