39 lines
1.1 KiB
Bash
39 lines
1.1 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=gettext
|
|
pkgver=0.22.5
|
|
pkgrel=1
|
|
pkgdesc="GNU internationalization library"
|
|
arch=('x86_64')
|
|
url="https://www.gnu.org/software/gettext/"
|
|
license=('GPL-2.0-only' 'LGPL-2.0-only' 'GFDL-1.2-only' 'GPL-2.0-or-later')
|
|
groups=('base' 'base-devel')
|
|
depends=('gcc-libs' 'acl' 'bash')
|
|
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(fe10c37353213d78a5b83d48af231e005c4da84db5ce88037d88355938259640)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/${pkgname}-${pkgver}
|
|
|
|
sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' \
|
|
-i gettext-{tools,runtime,runtime/libasprintf}/libtool
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
|
|
chmod -v 0755 ${pkgdir}/usr/lib64/preloadable_libintl.so
|
|
}
|