32 lines
855 B
Bash
32 lines
855 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=gperf
|
|
pkgver=3.1
|
|
pkgrel=1
|
|
pkgdesc="Perfect hash function generator"
|
|
arch=('x86_64')
|
|
url="https://www.gnu.org/software/gperf/"
|
|
license=('GPL-3.0-or-later')
|
|
depends=('gcc-libs' 'glibc')
|
|
options=('!makeflags')
|
|
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(588546b945bba4b70b6a3a616e80b4ab466e3f33024a352fc2198112cdbb3ae2)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --docdir=/usr/share/doc/${pkgname}-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|