39 lines
886 B
Bash
39 lines
886 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=grep
|
|
pkgver=3.11
|
|
pkgrel=1
|
|
pkgdesc="A string search utility"
|
|
arch=('x86_64')
|
|
url="https://www.gnu.org/software/grep/"
|
|
license=('GPL3')
|
|
groups=('base' 'base-devel')
|
|
depends=('glibc')
|
|
makedepends=('texinfo')
|
|
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(1db2aedde89d0dea42b16d9528f894c8d15dae4e190b59aecc78f5a951276eab)
|
|
|
|
prepare() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
sed -i "s/echo/#echo/" src/egrep.sh
|
|
}
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|