39 lines
999 B
Bash
39 lines
999 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=intltool
|
|
pkgver=0.51.0
|
|
pkgrel=1
|
|
pkgdesc="The internationalization tool collection"
|
|
arch=('x86_64')
|
|
url="https://freedesktop.org/wiki/Software/intltool"
|
|
license=('GPL')
|
|
depends=('perl-xml-parser')
|
|
source=(https://launchpad.net/intltool/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd)
|
|
|
|
prepare() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
sed -i 's:\\\${:\\\$\\{:' intltool-update.in
|
|
}
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
|
|
install -v -Dm644 doc/I18N-HOWTO ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/I18N-HOWTO
|
|
}
|