34 lines
941 B
Bash
34 lines
941 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=libarchive
|
|
pkgver=3.7.4
|
|
pkgrel=1
|
|
pkgdesc="Multi-format archive and compression library"
|
|
arch=('x86_64')
|
|
url="https://libarchive.org/"
|
|
license=('BSD')
|
|
depends=('acl' 'bzip2' 'expat' 'openssl' 'xz' 'zlib' 'zstd')
|
|
source=(https://github.com/libarchive/libarchive/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(f887755c434a736a609cbd28d87ddbfbe9d6a3bb5b703c22c02f6af80a802735)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-static \
|
|
--without-expat \
|
|
--without-nettle
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|