35 lines
968 B
Bash
35 lines
968 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=mpc
|
|
pkgver=1.3.1
|
|
pkgrel=1
|
|
pkgdesc="Library for the arithmetic of complex numbers with arbitrarily high precision"
|
|
arch=('x86_64')
|
|
url="https://www.multiprecision.org/"
|
|
license=('LGPL-3.0-only')
|
|
depends=('glibc' 'gmp' 'mpfr')
|
|
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(ab642492f5cf882b74aa0cb730cd410a81edcdbec895183ce930e706c1c759b8)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/${pkgname}-${pkgver}
|
|
|
|
make
|
|
make html
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
make DESTDIR=${pkgdir} install-html
|
|
}
|