Core/procps-ng/PKGBUILD
2024-09-07 23:18:11 +08:00

37 lines
1.0 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=procps-ng
pkgver=4.0.4
pkgrel=1
pkgdesc="Utilities for monitoring your system and its processes"
arch=('x86_64')
url="https://sourceforge.net/projects/procps-ng"
license=('GPL' 'LGPL')
groups=('base')
depends=('glibc' 'ncurses' 'systemd')
options=('!emptydirs')
source=(https://sourceforge.net/projects/procps-ng/files/Production/${pkgname}-${pkgver}.tar.xz)
sha256sums=(22870d6feb2478adb617ce4f09a787addaf2d260c5a8aa7b17d889a962c5e42e)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--disable-static \
--disable-kill \
--with-systemd \
--docdir=/usr/share/doc/${pkgname}-${pkgver}
make src_w_LDADD='$(LDADD) -lsystemd'
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}