32 lines
797 B
Bash
32 lines
797 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=psmisc
|
|
pkgver=23.7
|
|
pkgrel=1
|
|
pkgdesc="Miscellaneous procfs tools"
|
|
arch=('x86_64')
|
|
url="https://gitlab.com/psmisc/psmisc"
|
|
license=('GPL')
|
|
groups=('base')
|
|
depends=('ncurses')
|
|
source=(https://sourceforge.net/projects/psmisc/files/${pkgname}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(58c55d9c1402474065adae669511c191de374b0871eec781239ab400b907c327)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|