Core/zlib/PKGBUILD
2024-09-07 23:18:11 +08:00

32 lines
872 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=zlib
pkgver=1.3.1
pkgrel=1
pkgdesc="Compression library implementing the deflate compression method found in gzip and PKZIP"
arch=('x86_64')
url="https://www.zlib.net"
license=('Zlib')
depends=('glibc')
source=(https://zlib.net/fossils/${pkgname}-${pkgver}.tar.gz)
sha256sums=(9a93b2b7dfdac77ceba5a558a580e74667dd6fede4585b91eefb60f03b72df23)
build() {
cd ${pkgname}-${pkgver}
CFLAGS+=" -ffat-lto-objects"
CC="${CHOST}-gcc" ./configure --prefix=/usr --libdir=/usr/lib64
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}