Extra/bc/PKGBUILD
2024-09-07 23:34:40 +08:00

31 lines
895 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=bc
pkgver=6.7.6
pkgrel=1
pkgdesc="Implementation of dc and POSIX bc with GNU extensions"
arch=('x86_64')
url="https://git.gavinhoward.com/gavin/bc"
license=('BSD-2-Clause')
depends=('readline' 'ncurses')
source=(https://github.com/gavinhoward/bc/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz)
sha256sums=(828f390c2a552cadbc8c8ad5fde6eeaee398dc8d59d706559158330f3629ce35)
build() {
cd ${pkgname}-${pkgver}
CC="${CHOST}-gcc" ./configure --prefix=/usr --libdir=/usr/lib64 -G -O3 -r
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}