31 lines
849 B
Bash
31 lines
849 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=check
|
|
pkgver=0.15.2
|
|
pkgrel=1
|
|
pkgdesc="A unit testing framework for C"
|
|
arch=('x86_64')
|
|
url="https://libcheck.github.io/check"
|
|
license=('LGPL')
|
|
depends=('gawk')
|
|
source=(https://github.com/libcheck/check/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(a8de4e0bacfb4d76dd1c618ded263523b53b85d92a146d8835eb1a52932fa20a)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} docdir=/usr/share/doc/${pkgname}-${pkgver} install
|
|
}
|