34 lines
1020 B
Bash
34 lines
1020 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=ninja
|
|
pkgver=1.12.1
|
|
pkgrel=1
|
|
pkgdesc="Small build system with a focus on speed"
|
|
arch=('x86_64')
|
|
url="https://ninja-build.org/"
|
|
license=('Apache')
|
|
depends=('gcc-libs')
|
|
makedepends=('python')
|
|
source=(https://github.com/ninja-build/ninja/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(821bdff48a3f683bc4bb3b6f0b5fe7b2d647cf65d52aeb63328c91a6c6df285a)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
python3 configure.py --bootstrap
|
|
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
install -vDm755 ninja ${pkgdir}/usr/bin/ninja
|
|
|
|
install -vDm644 misc/bash-completion ${pkgdir}/usr/share/bash-completion/completions/ninja
|
|
install -vDm644 misc/zsh-completion ${pkgdir}/usr/share/zsh/site-functions/_ninja
|
|
}
|