Perl/perl-xml-parser/PKGBUILD
2024-09-07 23:37:42 +08:00

32 lines
844 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=perl-xml-parser
pkgver=2.47
pkgrel=1
pkgdesc="Expat-based XML parser module for perl"
arch=('x86_64')
url="https://github.com/chorny/XML-Parser"
license=('GPL' 'PerlArtistic')
depends=('expat' 'perl')
options=('!emptydirs')
source=(https://cpan.metacpan.org/authors/id/T/TO/TODDR/XML-Parser-${pkgver}.tar.gz)
sha256sums=(ad4aae643ec784f489b956abe952432871a622d4e2b5c619e8855accbfc4d1d8)
build() {
cd XML-Parser-${pkgver}
perl Makefile.PL
make
}
package() {
cd XML-Parser-${pkgver}
make DESTDIR=${pkgdir} install
}