Python/python-packaging/PKGBUILD
2024-09-22 21:10:16 +08:00

30 lines
881 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Futura Linux Team <future_linux@163.com>
pkgname=python-packaging
pkgver=24.1
pkgrel=1
pkgdesc="Core utilities for Python packages"
arch=('x86_64')
url="https://pypi.org/project/packaging/"
license=('Apache')
depends=('python')
makedepends=('python-installer' 'python-flit-core')
source=(https://github.com/pypa/packaging/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(7b31090ae4ddd6c48a5ed10073a880e6e2612ce8ac2f81e34f42aaabefd1b81b)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m flit_core.wheel
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer -d ${pkgdir} dist/*.whl
}