bash-completion/PKGBUILD
2024-10-16 02:35:57 +08:00

35 lines
992 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=bash-completion
pkgver=2.14.0
pkgrel=1
pkgdesc="Programmable completion for the bash shell"
arch=('x86_64')
url="https://github.com/scop/bash-completion"
license=('GPL2')
depends=('bash')
options=('!emptydirs' '!makeflags')
source=(https://github.com/scop/bash-completion/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz)
sha256sums=(5c7494f968280832d6adb5aa19f745a56f1a79df311e59338c5efa6f7285e168)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} --sysconfdir=/etc
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
rm -v ${pkgdir}/etc/profile.d/bash_completion.sh
rm -v ${pkgdir}/usr/share/bash-completion/completions/makepkg
}