binutils 2.43.1-1
This commit is contained in:
parent
f46905490e
commit
1ca87e2509
44
PKGBUILD
44
PKGBUILD
@ -5,24 +5,28 @@
|
|||||||
|
|
||||||
# Maintainer: Future Linux Team <future_linux@163.com>
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
||||||
pkgname=binutils
|
pkgname=binutils
|
||||||
pkgver=2.42
|
pkgver=2.43.1
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="A set of programs to assemble and manipulate binary and object files"
|
pkgdesc="A set of programs to assemble and manipulate binary and object files"
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url="https://www.gnu.org/software/binutils/"
|
url="https://www.gnu.org/software/binutils/"
|
||||||
license=('GPL-2.0-or-later' 'GPL-3.0-or-later' 'LGPL-2.0-or-later' 'LGPL-3.0-or-later' 'GFDL-1.3' 'FSFAP')
|
license=('GPL-2.0-or-later' 'GPL-3.0-or-later' 'LGPL-2.0-or-later' 'LGPL-3.0-or-later' 'GFDL-1.3' 'FSFAP')
|
||||||
groups=('base-devel')
|
groups=('base-devel')
|
||||||
depends=('glibc' 'zlib' 'zstd')
|
depends=('glibc' 'zlib' 'zstd' 'jansson' 'libelf')
|
||||||
backup=(etc/gprofng.rc)
|
backup=(etc/gprofng.rc)
|
||||||
options=('!distcc' '!ccache')
|
options=('!distcc' '!ccache')
|
||||||
source=(https://sourceware.org/pub/${pkgname}/releases/${pkgname}-${pkgver}.tar.xz)
|
source=(https://sourceware.org/pub/${pkgname}/releases/${pkgname}-${pkgver}.tar.xz
|
||||||
sha256sums=(f6e4d41fd5fc778b06b7891457b3620da5ecea1006c6a4a41ae998109f85a800)
|
gold-warn-unsupported.patch)
|
||||||
|
sha256sums=(13f74202a3c4c51118b797a39ea4200d3f6cfbe224da6d1d95bb938480132dfd
|
||||||
|
2d430b66f84a19c154725ec535280c493be1d34f1a90f95208dce02fecd0e4e4)
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd ${pkgname}-${pkgver}
|
cd ${pkgname}-${pkgver}
|
||||||
|
|
||||||
mkdir -v build
|
mkdir -v build
|
||||||
|
|
||||||
|
patch -Np1 -i ${srcdir}/gold-warn-unsupported.patch
|
||||||
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
@ -31,18 +35,32 @@ build() {
|
|||||||
${BUILD_CONFIGURE} \
|
${BUILD_CONFIGURE} \
|
||||||
--target=${CHOST} \
|
--target=${CHOST} \
|
||||||
--sysconfdir=/etc \
|
--sysconfdir=/etc \
|
||||||
|
--with-lib-path=/usr/lib64 \
|
||||||
--enable-cet \
|
--enable-cet \
|
||||||
--enable-gold \
|
--enable-colored-disassembly \
|
||||||
--enable-ld=default \
|
|
||||||
--enable-plugins \
|
|
||||||
--enable-shared \
|
|
||||||
--disable-werror \
|
|
||||||
--enable-64-bit-bfd \
|
|
||||||
--with-system-zlib \
|
|
||||||
--with-pic \
|
|
||||||
--enable-default-execstack=no \
|
--enable-default-execstack=no \
|
||||||
|
--enable-deterministic-archives \
|
||||||
|
--enable-gold \
|
||||||
|
--enable-install-libiberty \
|
||||||
|
--enable-jansson \
|
||||||
|
--enable-ld=default \
|
||||||
|
--enable-new-dtags \
|
||||||
|
--enable-pgo-build=lto \
|
||||||
|
--enable-plugins \
|
||||||
|
--enable-relro \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-targets=x86_64-pep,bpf-unknown-none \
|
||||||
|
--enable-threads \
|
||||||
--disable-gdb \
|
--disable-gdb \
|
||||||
--enable-default-hash-style=gnu
|
--disable-gdbserver \
|
||||||
|
--disable-libdecnumber \
|
||||||
|
--disable-readline \
|
||||||
|
--disable-sim \
|
||||||
|
--disable-werror \
|
||||||
|
--with-debuginfod \
|
||||||
|
--with-pic \
|
||||||
|
--with-system-zlib \
|
||||||
|
--with-bugurl=https://gitea.futurelinux.xyz/packages/binutils/issues
|
||||||
|
|
||||||
make tooldir=/usr
|
make tooldir=/usr
|
||||||
}
|
}
|
||||||
|
66
gold-warn-unsupported.patch
Normal file
66
gold-warn-unsupported.patch
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
Only in binutils-2.34/gold: autom4te.cache
|
||||||
|
diff -rup binutils.orig/gold/configure binutils-2.34/gold/configure
|
||||||
|
--- binutils.orig/gold/configure 2020-04-20 12:35:13.048297305 +0100
|
||||||
|
+++ binutils-2.34/gold/configure 2020-04-20 14:02:06.743725696 +0100
|
||||||
|
@@ -5180,7 +5180,8 @@ for targ in $target $canon_targets; do
|
||||||
|
. ${srcdir}/configure.tgt
|
||||||
|
|
||||||
|
if test "$targ_obj" = "UNKNOWN"; then
|
||||||
|
- as_fn_error $? "\"unsupported target $targ\"" "$LINENO" 5
|
||||||
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: \"unsupported target $targ\"" >&5
|
||||||
|
+$as_echo "$as_me: WARNING: \"unsupported target $targ\"" >&2;}
|
||||||
|
else
|
||||||
|
targetobjs="$targetobjs ${targ_obj}.\$(OBJEXT)"
|
||||||
|
if test "$targ_extra_obj" != ""; then
|
||||||
|
diff -rup binutils.orig/gold/configure.ac binutils-2.34/gold/configure.ac
|
||||||
|
--- binutils.orig/gold/configure.ac 2020-04-20 12:35:13.050297291 +0100
|
||||||
|
+++ binutils-2.34/gold/configure.ac 2020-04-20 14:01:46.435868770 +0100
|
||||||
|
@@ -181,7 +181,7 @@ for targ in $target $canon_targets; do
|
||||||
|
. ${srcdir}/configure.tgt
|
||||||
|
|
||||||
|
if test "$targ_obj" = "UNKNOWN"; then
|
||||||
|
- AC_MSG_ERROR("unsupported target $targ")
|
||||||
|
+ AC_MSG_WARN("unsupported target $targ")
|
||||||
|
else
|
||||||
|
targetobjs="$targetobjs ${targ_obj}.\$(OBJEXT)"
|
||||||
|
if test "$targ_extra_obj" != ""; then
|
||||||
|
--- binutils.orig/ld/configure.tgt 2020-04-20 12:35:12.465301359 +0100
|
||||||
|
+++ binutils-2.34/ld/configure.tgt 2020-04-20 14:17:52.123066333 +0100
|
||||||
|
@@ -220,7 +220,7 @@ bfin-*-linux-uclibc*) targ_emul=elf32bfi
|
||||||
|
targ_extra_emuls="elf32bfin"
|
||||||
|
targ_extra_libpath=$targ_extra_emuls
|
||||||
|
;;
|
||||||
|
-bpf-*-*) targ_emul=elf64bpf
|
||||||
|
+bpf-* | bpf-*-*) targ_emul=elf64bpf
|
||||||
|
;;
|
||||||
|
cr16-*-elf*) targ_emul=elf32cr16
|
||||||
|
;;
|
||||||
|
@@ -1026,7 +1026,7 @@ z8k-*-coff) targ_emul=z8002
|
||||||
|
targ_extra_ofiles=
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
- echo 2>&1 "*** ld does not support target ${targ}"
|
||||||
|
+ echo 2>&1 "*** ld does not support target '${targ}' NO REALLY"
|
||||||
|
echo 2>&1 "*** see ld/configure.tgt for supported targets"
|
||||||
|
exit 1
|
||||||
|
|
||||||
|
--- binutils.orig/bfd/config.bfd 2020-04-20 12:35:13.038297375 +0100
|
||||||
|
+++ binutils-2.34/bfd/config.bfd 2020-04-20 14:25:26.452869193 +0100
|
||||||
|
@@ -473,7 +473,7 @@ case "${targ}" in
|
||||||
|
;;
|
||||||
|
|
||||||
|
#ifdef BFD64
|
||||||
|
- bpf-*-none)
|
||||||
|
+ bpf-*-none | bpf-*)
|
||||||
|
targ_defvec=bpf_elf64_le_vec
|
||||||
|
targ_selvecs=bpf_elf64_be_vec
|
||||||
|
targ_underscore=yes
|
||||||
|
@@ -1427,7 +1427,7 @@ case "${targ}" in
|
||||||
|
;;
|
||||||
|
|
||||||
|
*)
|
||||||
|
- echo 1>&2 "*** BFD does not support target ${targ}."
|
||||||
|
+ echo 1>&2 "*** BFD does not support target '${targ}'. Honest."
|
||||||
|
echo 1>&2 "*** Look in bfd/config.bfd for supported targets."
|
||||||
|
exit 1
|
||||||
|
;;
|
Loading…
Reference in New Issue
Block a user