46 lines
1.5 KiB
Bash
46 lines
1.5 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=boost
|
|
pkgver=1.86.0
|
|
pkgrel=1
|
|
pkgdesc="Free peer-reviewed portable C++ source libraries"
|
|
arch=('x86_64')
|
|
url="https://www.boost.org"
|
|
license=('BSL-1.0')
|
|
depends=('icu' 'python' 'bzip2' 'zlib' 'zstd')
|
|
source=(https://github.com/boostorg/boost/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}-b2-nodocs.tar.xz)
|
|
sha256sums=(a4d99d032ab74c9c5e76eddcecc4489134282245fffa7e079c5804b92b45f51d)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
./bootstrap.sh \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib64 \
|
|
--with-python=python3 \
|
|
--with-icu \
|
|
--with-toolset=gcc \
|
|
--with-python-version="$(python3 -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
|
|
|
|
./b2 stage ${MAKEFLAGS} threading=multi link=shared runtime-link=shared toolset=gcc --cxxflags="${CXXFLAGS} ${LDFLAGS}"
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
./b2 install \
|
|
threading=multi \
|
|
link=shared \
|
|
toolset=gcc \
|
|
runtime-link=shared \
|
|
cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3 -ffat-lto-objects" \
|
|
cxxflags="${CPPFLAGS} ${CXXFLAGS} -fPIC -O3 -ffat-lto-objects" \
|
|
linkflags="${LDFLAGS}" \
|
|
--prefix=${pkgdir}/usr \
|
|
--libdir=${pkgdir}/usr/lib64
|
|
}
|