cdparanoia-III/PKGBUILD
2024-04-17 11:07:25 +08:00

58 lines
1.7 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=cdparanoia-III
pkgver=10.2
pkgrel=1
pkgdesc="Compact Disc Digital Audio extraction tool"
arch=('x86_64')
url="https://www.xiph.org/paranoia/"
license=('GPL')
depends=('glibc')
options=('!makeflags')
source=(https://downloads.xiph.org/releases/cdparanoia/${pkgname}-${pkgver}.src.tgz
${pkgname}-${pkgver}-format-security.patch
${pkgname}-${pkgver}-gcc_fixes-1.patch
${pkgname}-${pkgver}-install.patch
${pkgname}-${pkgver}-ldflags.patch)
sha256sums=(005db45ef4ee017f5c32ec124f913a0546e77014266c6a1c50df902a55fe64df
a6f80215c801190dfcade6751d12235a1878ab6b5762260086e7f0ce1296bef4
0a0416252c0e0ba9362ca67de75b3bd599c1f8b559c2663328c5f1dbecdc2d90
807c72330ebde3fc0c26a10ed7236870f49ae11df75dd8bd2be9c593e774806a
9b352a93ebedc7c523c76213756f98139ea3912162ee719ab0c5cc6648f94fe2)
prepare() {
cd ${pkgname}-${pkgver}
patch -Np1 -i ${srcdir}/${pkgname}-${pkgver}-gcc_fixes-1.patch
# Add missing printf format strings for `-Wformat -Werror=format-security`
patch -Np1 -i ${srcdir}/${pkgname}-${pkgver}-format-security.patch
# Use LDFLAGS
patch -Np1 -i ${srcdir}/${pkgname}-${pkgver}-ldflags.patch
patch -Np1 -i ${srcdir}/${pkgname}-${pkgver}-install.patch
autoreconf -ifv
}
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} --mandir=/usr/share/man
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
chmod -v 755 ${pkgdir}/usr/lib64/libcdda_*.so.0.${pkgver}
}