31 lines
810 B
Bash
31 lines
810 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=darts
|
|
pkgver=0.32
|
|
pkgrel=1
|
|
pkgdesc="C++ Template Library for implementation of Double-Array"
|
|
arch=('x86_64')
|
|
url="http://chasen.org/~taku/software/darts/"
|
|
license=('BSD' 'LGPL')
|
|
depends=('gcc-libs')
|
|
source=(http://chasen.org/~taku/software/darts/src/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(0dfc0b82f0a05d93b92acf849368e54bf93f1de8ffb31ba0a21e45ab9e269285)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|