35 lines
1004 B
Bash
35 lines
1004 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=double-conversion
|
|
pkgver=3.3.0
|
|
pkgrel=1
|
|
pkgdesc="Binary-decimal and decimal-binary routines for IEEE doubles"
|
|
arch=('x86_64')
|
|
url="https://github.com/google/double-conversion"
|
|
license=('BSD')
|
|
depends=('gcc-libs')
|
|
makedepends=('cmake')
|
|
source=(https://github.com/google/double-conversion/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(04ec44461850abbf33824da84978043b22554896b552c5fd11a9c5ae4b4d296e)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DBUILD_SHARED_LIBS=ON \
|
|
-DBUILD_TESTING=ON \
|
|
-B build
|
|
|
|
cmake --build build
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
DESTDIR=${pkgdir} cmake --install build
|
|
}
|