efibootmgr/PKGBUILD
2024-10-31 15:01:04 +08:00

29 lines
925 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <xhaa123@outlook.com>
pkgname=efibootmgr
pkgver=18
pkgrel=2
pkgdesc="Linux user-space application to modify the EFI Boot Manager"
arch=('x86_64')
url="https://github.com/rhboot/efibootmgr"
license=('GPL-2.0-or-later')
depends=('glibc' 'popt' 'efivar')
source=(https://github.com/rhboot/efibootmgr/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
sha256sums=(442867d12f8525034a404fc8af3036dba8e1fc970998af2486c3b940dfad0874)
build() {
cd ${pkgname}-${pkgver}
CC=${CHOST}-gcc CXX=${CHOST}-g++ make EFIDIR=future EFI_LOADER=grubx64.efi
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install EFIDIR=future
}