30 lines
889 B
Bash
30 lines
889 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <xhaa123@outlook.com>
|
|
pkgname=efivar
|
|
pkgver=39
|
|
pkgrel=1
|
|
pkgdesc="Tools and libraries to work with EFI variables"
|
|
arch=('x86_64')
|
|
url="https://github.com/rhboot/efivar"
|
|
license=('LGPL-2.1-or-later')
|
|
depends=('glibc')
|
|
makedepends=('mandoc')
|
|
source=(https://github.com/rhboot/efivar/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
|
|
sha256sums=(c9edd15f2eeeea63232f3e669a48e992c7be9aff57ee22672ac31f5eca1609a6)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
CC=${CHOST}-gcc CXX=${CHOST}-g++ make ERRORS='' all
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} LIBDIR=/usr/lib64 install
|
|
}
|