fcitx5-lua/PKGBUILD
2024-08-13 18:55:13 +08:00

34 lines
970 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=fcitx5-lua
pkgver=5.0.13
pkgrel=1
pkgdesc="Lua support for Fcitx 5"
arch=('x86_64')
url="https://github.com/fcitx/fcitx5-lua"
license=('GPL')
depends=('fcitx5' 'lua')
makedepends=('extra-cmake-modules' 'cmake')
source=(https://github.com/fcitx/fcitx5-lua/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
sha256sums=(f39932c7425cf0e33e9fa75cc63775ad5095d719ea9bd2a84d37bfb9d14e9309)
build() {
cd ${pkgname}-${pkgver}
cmake -Bbuild \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib64
cmake --build build
}
package() {
cd ${pkgname}-${pkgver}
DESTDIR=${pkgdir} cmake --install build
}