future-install-scripts 29-1

This commit is contained in:
xhaa123 2024-10-29 20:45:00 +08:00
parent 79dc988cf3
commit 894b7a4462
3 changed files with 75 additions and 61 deletions

View File

@ -1,18 +0,0 @@
From 7b5405d46e0e90f66127796587e04277669ba9a6 Mon Sep 17 00:00:00 2001
From: xhaa123 <xhaa123@future_linux@163.com>
Date: Sun, 28 Apr 2024 06:35:43 +0800
Subject: [PATCH] =?UTF-8?q?=E6=9B=B4=E6=96=B0=20doc/future-chroot.8.asciid?=
=?UTF-8?q?oc?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
---
doc/{arch-chroot.8.asciidoc => future-chroot.8.asciidoc} | 0
1 file changed, 0 insertions(+), 0 deletions(-)
rename doc/{arch-chroot.8.asciidoc => future-chroot.8.asciidoc} (100%)
diff --git a/doc/arch-chroot.8.asciidoc b/doc/future-chroot.8.asciidoc
similarity index 100%
rename from doc/arch-chroot.8.asciidoc
rename to doc/future-chroot.8.asciidoc

View File

@ -5,42 +5,39 @@
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=future-install-scripts
pkgver=v28+r58+g2767ea5
pkgver=29
pkgrel=1
pkgdesc="Scripts to aid in installing Future Linux"
arch=('x86_64')
url="https://gitlab.archlinux.org/archlinux/arch-install-scripts"
license=('GPL2')
license=('GPL-2.0-only')
depends=('gawk' 'bash' 'coreutils' 'grep' 'pacman' 'util-linux')
makedepends=('git' 'python-asciidoc' 'libxslt' 'docbook-xml' 'docbook-xsl')
source=(git+https://gitlab.archlinux.org/archlinux/arch-install-scripts.git
5888340bfe.patch
7b5405d46e0e90f66127796587e04277669ba9a6.patch)
makedepends=('git' 'python-asciidoc')
source=(git+https://gitlab.archlinux.org/archlinux/arch-install-scripts.git#tag=v${pkgver}
b53d472be3.patch)
sha256sums=(SKIP
bea3806e5649d3a2267684dbce6a3f7d265820d991ead08dec54be1de7a08763
0fdf121581f2e53971d91292b1bc2626e83a59637401d461aac4b3dbe930b5e6)
9236d6a4a0ba586f3c7184e7379b8e3e94548c365e65cd312983eb7e661ee673)
pkgver() {
cd arch-install-scripts
cd arch-install-scripts
git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
git describe | sed 's/^v//'
}
prepare() {
cd arch-install-scripts
cd arch-install-scripts
git apply ${srcdir}/5888340bfe.patch
git apply ${srcdir}/7b5405d46e0e90f66127796587e04277669ba9a6.patch
git apply ${srcdir}/b53d472be3.patch
}
build() {
cd arch-install-scripts
cd arch-install-scripts
make
make
}
package() {
cd arch-install-scripts
cd arch-install-scripts
make DESTDIR=${pkgdir} install
make DESTDIR=${pkgdir} install
}

View File

@ -1,21 +1,21 @@
From 5888340bfe6f2f9b51e7fb3566ceb9aa623a872e Mon Sep 17 00:00:00 2001
From b53d472be37994ec39a7f37e3f817bf5f4f9154a Mon Sep 17 00:00:00 2001
From: xhaa123 <xhaa123@outlook.com>
Date: Sun, 28 Apr 2024 05:42:50 +0800
Subject: [PATCH] =?UTF-8?q?=E4=B8=80=E4=BA=9B=E4=BF=AE=E6=94=B9?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Date: Tue, 29 Oct 2024 12:28:58 +0800
Subject: [PATCH] Modify Arch Install Scripts to work with Future Linux Install
Scripts
---
Makefile | 12 ++++++------
common | 12 +++++-------
completion/bash/{arch-chroot => future-chroot} | 4 ++--
completion/zsh/{_arch-chroot => _future-chroot} | 2 +-
doc/arch-chroot.8.asciidoc | 10 +++++-----
arch-chroot.in => future-chroot.in | 8 ++++----
6 files changed, 23 insertions(+), 25 deletions(-)
Makefile | 12 +++++-----
README.md | 6 +++--
common | 23 +++++++++----------
.../bash/{arch-chroot => future-chroot} | 4 ++--
.../zsh/{_arch-chroot => _future-chroot} | 2 +-
...ot.8.asciidoc => future-chroot.8.asciidoc} | 10 ++++----
arch-chroot.in => future-chroot.in | 8 +++----
7 files changed, 33 insertions(+), 32 deletions(-)
rename completion/bash/{arch-chroot => future-chroot} (88%)
rename completion/zsh/{_arch-chroot => _future-chroot} (97%)
rename doc/{arch-chroot.8.asciidoc => future-chroot.8.asciidoc} (80%)
rename arch-chroot.in => future-chroot.in (94%)
diff --git a/Makefile b/Makefile
@ -60,36 +60,68 @@ index d2928a5..7026b3a 100644
install -d $(DESTDIR)$(PREFIX)/share/zsh/site-functions
install -m 0644 $(ZSHCOMP) $(DESTDIR)$(PREFIX)/share/zsh/site-functions
install -d $(DESTDIR)$(PREFIX)/share/bash-completion/completions
diff --git a/README.md b/README.md
index 348db42..6198a36 100644
--- a/README.md
+++ b/README.md
@@ -1,7 +1,9 @@
-# Arch Install Scripts
+# Modify Arch Install Scripts
+
+# Future Install Scripts
This is a small suite of scripts aimed at automating some menial
-tasks when installing [Arch Linux](https://www.archlinux.org).
+tasks when installing [Future Linux](https://www.futurelinux.xyz).
## Requirements
diff --git a/common b/common
index 431064c..43abc77 100644
index ced125b..53c17cc 100644
--- a/common
+++ b/common
@@ -30,14 +30,13 @@ chroot_setup() {
@@ -29,15 +29,15 @@ chroot_setup() {
[[ $(trap -p EXIT) ]] && die '(BUG): attempting to overwrite existing EXIT trap'
trap 'chroot_teardown' EXIT
chroot_add_mount proc "$1/proc" -t proc -o nosuid,noexec,nodev &&
- chroot_add_mount proc "$1/proc" -t proc -o nosuid,noexec,nodev &&
- chroot_add_mount sys "$1/sys" -t sysfs -o nosuid,noexec,nodev,ro &&
+ chroot_add_mount sysfs "$1/sys" -t sysfs -o nosuid,noexec,nodev,ro &&
+ chroot_add_mount --bind /dev "$1/dev" &&
+ chroot_add_mount devpts "$1/dev/pts" -t devpts -o gid=5,mode=0620 &&
+ chroot_add_mount proc $1/proc -t proc &&
+ chroot_add_mount sysfs $1/sys -t sysfs &&
+ chroot_add_mount tmpfs "$1/run" -t tmpfs &&
+ chroot_add_mount tmpfs "$1/dev/shm" -t tmpfs -o nosuid,nodev &&
ignore_error chroot_maybe_add_mount "[[ -d '$1/sys/firmware/efi/efivars' ]]" \
efivarfs "$1/sys/firmware/efi/efivars" -t efivarfs -o nosuid,noexec,nodev &&
- efivarfs "$1/sys/firmware/efi/efivars" -t efivarfs -o nosuid,noexec,nodev &&
- chroot_add_mount udev "$1/dev" -t devtmpfs -o mode=0755,nosuid &&
+ chroot_add_mount devtmpfs "$1/dev" -t devtmpfs -o mode=0755,nosuid &&
chroot_add_mount devpts "$1/dev/pts" -t devpts -o mode=0620,gid=5,nosuid,noexec &&
- chroot_add_mount devpts "$1/dev/pts" -t devpts -o mode=0620,gid=5,nosuid,noexec &&
- chroot_add_mount shm "$1/dev/shm" -t tmpfs -o mode=1777,nosuid,nodev &&
- chroot_add_mount /run "$1/run" --bind --make-private &&
- chroot_add_mount tmp "$1/tmp" -t tmpfs -o mode=1777,strictatime,nodev,nosuid
+ chroot_add_mount tmpfs "$1/dev/shm" -t tmpfs -o nosuid,nodev &&
+ chroot_add_mount tmpfs "$1/run" -t tmpfs -o mode=0755,nosuid,nodev
+ efivarfs "$1/sys/firmware/efi/efivars" -t efivarfs
+
}
chroot_teardown() {
@@ -81,8 +80,7 @@ unshare_setup() {
@@ -68,8 +68,8 @@ unshare_setup() {
trap 'unshare_teardown' EXIT
chroot_add_mount_lazy "$1" "$1" --bind &&
- chroot_add_mount proc "$1/proc" -t proc -o nosuid,noexec,nodev &&
- chroot_add_mount_lazy /sys "$1/sys" --rbind &&
+ chroot_add_mount proc "$1/proc" -t proc &&
+ chroot_add_mount sysfs "$1/sys" -t sysfs &&
chroot_add_link /proc/self/fd "$1/dev/fd" &&
chroot_add_link /proc/self/fd/0 "$1/dev/stdin" &&
chroot_add_link /proc/self/fd/1 "$1/dev/stdout" &&
@@ -80,8 +80,7 @@ unshare_setup() {
chroot_bind_device /dev/tty "$1/dev/tty" &&
chroot_bind_device /dev/urandom "$1/dev/urandom" &&
chroot_bind_device /dev/zero "$1/dev/zero" &&
- chroot_add_mount run "$1/run" -t tmpfs -o nosuid,nodev,mode=0755 &&
- chroot_add_mount tmp "$1/tmp" -t tmpfs -o mode=1777,strictatime,nodev,nosuid
+ chroot_add_mount tmpfs "$1/run" -t tmpfs -o nosuid,nodev,mode=0755
+ chroot_add_mount tmpfs "$1/run" -t tmpfs
}
unshare_teardown() {
@ -125,10 +157,13 @@ index 6229af8..985264a 100644
# NOTE: nearly everything here is borrowed from the chroot completion
local -a args=(
diff --git a/doc/arch-chroot.8.asciidoc b/doc/arch-chroot.8.asciidoc
diff --git a/doc/arch-chroot.8.asciidoc b/doc/future-chroot.8.asciidoc
similarity index 80%
rename from doc/arch-chroot.8.asciidoc
rename to doc/future-chroot.8.asciidoc
index 5f3f27c..e708639 100644
--- a/doc/arch-chroot.8.asciidoc
+++ b/doc/arch-chroot.8.asciidoc
+++ b/doc/future-chroot.8.asciidoc
@@ -1,21 +1,21 @@
-arch-chroot(8)
+future-chroot(8)