38 lines
1.0 KiB
Bash
38 lines
1.0 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=gsettings-desktop-schemas
|
|
pkgver=46.0
|
|
pkgrel=2
|
|
pkgdesc="Shared GSettings schemas for the desktop"
|
|
arch=('x86_64')
|
|
url="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
|
|
license=('LGPL-2.1-or-later')
|
|
depends=('glib2')
|
|
makedepends=('meson' 'gobject-introspection')
|
|
source=(https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(493a46a1161b6388d57aa72f632a79ce96c42d5ffbd1d0b00f496ec5876f8575)
|
|
|
|
prepare() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
sed -i -r 's:"(/system):"/org/gnome\1:g' schemas/*.in
|
|
}
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson setup build --prefix=/usr --buildtype=release
|
|
|
|
meson compile -C build
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson install -C build --destdir ${pkgdir}
|
|
}
|