gst-plugins-base/PKGBUILD

38 lines
1.2 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=gst-plugins-base
pkgver=1.24.2
pkgrel=1
pkgdesc="Multimedia graph framework - base plugins"
arch=('x86_64')
url="https://gstreamer.freedesktop.org/"
license=('LGPL-2.1-or-later')
depends=("gstreamer>=${pkgver}" 'alsa-lib' 'cdparanoia-III' 'glib2' 'iso-codes' 'libgudev'
'libjpeg-turbo' 'libogg' 'libpng' 'libvorbis' 'mesa' 'pango' 'wayland-protocols')
makedepends=('meson')
source=(https://gstreamer.freedesktop.org/src/${pkgname}/${pkgname}-${pkgver}.tar.xz)
sha256sums=(282f1cc8065c9b62eb6a0a20fb9e8328f8e5296df2458b7236daa729c41ae769)
build() {
cd ${pkgname}-${pkgver}
meson setup build \
--prefix=/usr \
--buildtype=release \
--wrap-mode=nodownload \
-Dpackage-name="GStreamer (Future Linux)" \
-Dpackage-origin="https://futurelinux.xyz"
meson compile -C build
}
package() {
cd ${pkgname}-${pkgver}
meson install -C build --destdir ${pkgdir}
}