38 lines
1.2 KiB
Bash
38 lines
1.2 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=gstreamer
|
|
pkgver=1.24.8
|
|
pkgrel=1
|
|
pkgdesc="Multimedia graph framework - core"
|
|
arch=('x86_64')
|
|
url="https://gstreamer.freedesktop.org/"
|
|
license=('LGPL-2.1-or-later')
|
|
depends=('gcc-libs' 'glib2' 'glibc' 'libcap' 'libelf' 'libunwind')
|
|
makedepends=('meson' 'gobject-introspection' 'bash-completion')
|
|
source=(https://gstreamer.freedesktop.org/src/${pkgname}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(b807dbf36c5d2b3ce1c604133ed0c737350f9523ce4d8d644a1177c5f9d6ded3)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
future-meson build \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib64 \
|
|
--buildtype=release \
|
|
-Dgst_debug=false \
|
|
-Dpackage-name="GStreamer (Future Linux)" \
|
|
-Dpackage-origin="https://futurelinux.xyz"
|
|
|
|
meson compile -C build
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson install -C build --destdir ${pkgdir}
|
|
}
|