hidapi/PKGBUILD
2024-10-30 01:33:42 +08:00

35 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=hidapi
pkgver=0.14.0
pkgrel=1
pkgdesc="Simple library for communicating with USB and Bluetooth HID devices"
arch=('x86_64')
url="https://github.com/libusb/hidapi"
license=('GPL3' 'BSD' 'custom')
depends=('systemd')
makedepends=('cmake' 'libusb')
source=(https://github.com/libusb/${pkgname}/archive/${pkgname}-${pkgver}/${pkgname}-${pkgname}-${pkgver}.tar.gz)
sha256sums=(a5714234abe6e1f53647dd8cba7d69f65f71c558b7896ed218864ffcf405bcbd)
build() {
cd ${pkgname}-${pkgname}-${pkgver}
cmake -Bbuild \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=lib64
cmake --build build
}
package() {
cd ${pkgname}-${pkgname}-${pkgver}
DESTDIR=${pkgdir} cmake --install build
}