icu 74.2-1

This commit is contained in:
xhaa123 2024-11-05 11:33:29 +08:00
commit 3ee624dcfe
2 changed files with 66 additions and 0 deletions

25
ICU-22132.patch Normal file
View File

@ -0,0 +1,25 @@
diff -u a/i18n/vtzone.cpp a/i18n/vtzone.cpp
--- a/i18n/vtzone.cpp 2023-07-14 09:05:38.000000000 +0100
+++ b/i18n/vtzone.cpp 2023-07-14 09:05:38.000000000 +0100
@@ -1735,14 +1735,14 @@
}
}
} else {
- UnicodeString icutzprop;
- UVector customProps(nullptr, uhash_compareUnicodeString, status);
+ UVector customProps(uprv_deleteUObject, uhash_compareUnicodeString, status);
if (olsonzid.length() > 0 && icutzver.length() > 0) {
- icutzprop.append(olsonzid);
- icutzprop.append(u'[');
- icutzprop.append(icutzver);
- icutzprop.append(u']');
- customProps.addElement(&icutzprop, status);
+ LocalPointer<UnicodeString> icutzprop(new UnicodeString(ICU_TZINFO_PROP), status);
+ icutzprop->append(olsonzid);
+ icutzprop->append(u'[');
+ icutzprop->append(icutzver);
+ icutzprop->append(u']');
+ customProps.adoptElement(icutzprop.orphan(), status);
}
writeZone(writer, *tz, &customProps, status);
}

41
PKGBUILD Normal file
View File

@ -0,0 +1,41 @@
# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=icu
pkgver=74.2
pkgrel=1
pkgdesc="International Components for Unicode library"
arch=('x86_64')
url="https://icu.unicode.org"
license=('LicenseRef-Unicode-3.0' 'BSD-2-Clause''BSD-3-Clause')
depends=('gcc-libs' 'glibc' 'bash')
makedepends=('python')
source=(https://github.com/unicode-org/icu/releases/download/release-${pkgver//./-}/icu4c-${pkgver//./_}-src.tgz
ICU-22132.patch)
sha256sums=(68db082212a96d6f53e35d60f47d38b962e9f9d207a74cfac78029ae8ff5e08c
5c99100fe57dd16d0489a45264a501c023751ed58823d334a3f8a51786bdb7a5)
prepare() {
cd ${pkgname}/source
# Required fix for thunderbird 115 to show Calendar and sidebar properly
patch -Np1 < ${srcdir}/ICU-22132.patch
}
build() {
cd ${pkgname}/source
${CONFIGURE}
make
}
package() {
cd ${pkgname}/source
make DESTDIR=${pkgdir} install
}