icu/PKGBUILD
2024-11-05 11:34:21 +08:00

42 lines
1.1 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=icu
pkgver=75.1
pkgrel=1
pkgdesc="International Components for Unicode library"
arch=('x86_64')
url="https://icu.unicode.org"
license=('LicenseRef-Unicode-3.0' 'BSD-2-Clause''BSD-3-Clause')
depends=('gcc-libs' 'glibc' 'bash')
makedepends=('python')
source=(https://github.com/unicode-org/icu/releases/download/release-${pkgver//./-}/icu4c-${pkgver//./_}-src.tgz
ICU-22132.patch)
sha256sums=(cb968df3e4d2e87e8b11c49a5d01c787bd13b9545280fc6642f826527618caef
5c99100fe57dd16d0489a45264a501c023751ed58823d334a3f8a51786bdb7a5)
prepare() {
cd ${pkgname}/source
# Required fix for thunderbird 115 to show Calendar and sidebar properly
patch -Np1 < ${srcdir}/ICU-22132.patch
}
build() {
cd ${pkgname}/source
${CONFIGURE}
make
}
package() {
cd ${pkgname}/source
make DESTDIR=${pkgdir} install
}