51 lines
1.5 KiB
Bash
51 lines
1.5 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=iksemel
|
|
pkgver=1.6.2
|
|
pkgrel=1
|
|
pkgdesc="Iksemel is a fast xml decoder API used by Jabber."
|
|
arch=('x86_64')
|
|
url="https://github.com/Zaryob/iksemel"
|
|
license=('LGPL-2.1-or-later')
|
|
depends=('glibc' 'python' 'openssl')
|
|
makedepends=('ninja' 'meson')
|
|
source=(https://github.com/Zaryob/iksemel/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz
|
|
${pkgname}-${pkgver}.dist-info.tar.gz)
|
|
sha256sums=(8055705c89df7fc0c64d7052188650dfdf3e049da8a7700f19240d8948ecb16c
|
|
78fafc64a6b45ab8adbaa6d4bf6861f6612cdb541487b805df5dbf1e4ee5be46)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
CFLAGS+=" -Wimplicit-function-declaration"
|
|
CXXFLAGS+=" -Wimplicit-function-declaration"
|
|
|
|
export CFLAGS CXXFLAGS
|
|
|
|
future-meson build \
|
|
--prefix /usr \
|
|
--buildtype=release \
|
|
--libdir=/usr/lib64 \
|
|
-Dopenssl=enabled \
|
|
-Dwith_tools=true \
|
|
-Dwith_python=true \
|
|
-Dtests=true
|
|
|
|
meson compile -C build
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson install -C build --destdir ${pkgdir}
|
|
|
|
local site_packages=$(python3 -c "import site; print(site.getsitepackages()[0])")
|
|
|
|
mv -v ${srcdir}/${pkgname}-${pkgver}.dist-info ${pkgdir}/${site_packages}/
|
|
|
|
}
|