31 lines
850 B
Bash
31 lines
850 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=jansson
|
|
pkgver=2.14
|
|
pkgrel=1
|
|
pkgdesc="C library for encoding, decoding and manipulating JSON data"
|
|
arch=('x86_64')
|
|
url="https://www.digip.org/jansson"
|
|
license=('MIT')
|
|
depends=('glibc')
|
|
source=(https://github.com/akheron/jansson/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.bz2)
|
|
sha256sums=(fba956f27c6ae56ce6dfd52fbf9d20254aad42821f74fa52f83957625294afb9)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} --disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|